Help setting up Cluster

I’m trying to setup and run my own cluster.
I go through all the setup from here:

I get to the step where it says to run
python -m pytest

to test everything. See attached picture for where it hangs up.

If I hit ctrl-c twice, I get this

Try docker because it’s much easier for setting up a QKC cluster.

Thank you. I have tried docker, and it is running, and currently syncing.

Question for when it finishes. How do I determine my cluster IP so I can use my GPUs to mine? Is it just my PC IP address on the computer I have running the cluster? Or is it the IP of my internet service provider?


If your miner is the same local network as the cluster, you can use your PC IP address.

If not, you should try the IP of your internet service provider.

I finally have my cluster fully synced and running.
I wound up setting it up on Digital Ocean.
I have a public IP address for my droplet on Digital Ocean.

When I try to mine to it, using my PC, I get the following error (see picture)

Can you please point me in the right direction? I know my ports are open (38291, 38391, 38491, TCP and UDP… on the droplet)

I’m thinking I need to change a setting in the cluster to allow an outside machine to mine?

I put in my docker IP address (which I assume is the cluster IP address) where the red star is.

When I run stats on the cluster, this is my output

IP = localhost

?? I assume that means it is the IP of my droplet on digital ocean?

I have been working with some people on the QKC discord… We did find that my port was not actually open. But it is now… when tested from Online Ping, Traceroute, DNS lookup, WHOIS, Port check, Reverse lookup, Proxy checker, Bandwidth meter, Network calculator, Network mask calculator, Country by IP, Unit converter
I now get this:

However, I get the same connection error in the miner.

I do see this from time to time as my cluster is running and scrolling… is this normal?

I also get this every now and then. Is this normal?

Sorry, one more picture of something that shows up as the cluster is running… Happens about 1 time per minute?

You cluster works well. Please ignore the error message, they didn’t matter. The error happened when you failed to connect some nodes.

Maybe you should try edit your cluster config.

vi mainnet/singularity/cluster_config_template.json

截屏2021-03-23 上午11.57.13

Restart and try mining again.

Thank you! That fixed the issue!